[libav-api] "undefined reference to XXXXX" - how to reinstall libav completely?

Luca Barbato lu_zero at gentoo.org
Mon May 16 13:31:57 CEST 2011


On 5/15/11 1:43 PM, wecing wrote:
> Hi all,
>
> After installing libav v0.7b, I found the API really changed too much for me
> to get it, so I covered it with v0.6.9.

The api should be more clear and straightforward now, please refer to 
libavformat/output-example.c and libavcodec/api-example.c

> Actually I did not run "make uninstall" under v0.7b's source directory -- I
> just "make install"ed v0.6.9 instead.
>
> Then I tried to compile dranger's tutorial as a test, but sadly got this:
> http://code.bulix.org/fio8nl-79874
> As you see, most of the error provided by gcc was "undefined reference to
> XXX".
> /home/wecing/source/libav-0.6.9 is where I uncompressed the source pack.
>
> Later I tried "rm -R /usr/local/include", "make uninstall" under v0.7b's
> source dir, and completely reconfigure, remake, and reinstalling v0.6.9 --
> but still, it doesn't work.
> Any ideas?

First, remind me/us to provide a better example, I'm afraid that that 
tutorial might be outdated.

Back to your actual problem you might want to use the pkg-config files 
so system deps or external deps like libz will be added when necessary.

e.g. on a macosx box

# pkg-config --static --libs libavcodec
-L/Users/lu_zero/Gentoo/usr/lib -lavcodec -lmp3lame -lfaac -lbz2 -lz 
-lavutil -lm

lu


More information about the libav-api mailing list