[libav-api] "marker does not match f_code" during decoding

Ronald S. Bultje rsbultje at gmail.com
Fri Apr 15 18:13:36 CEST 2011


Hi,

On Thu, Apr 14, 2011 at 10:11 PM, Jieyun Fu <jieyunfu at mit.edu> wrote:
> Hi all,
> I kept encoutering this error when decoding a video... Does anyone have any
> idea why this would happen?
> Thank you so much!
> [mpeg4 @ 0x7f39c58737c0] cbpc damaged at 0 0ime=4.04 bitrate=1159.8kbits/s
> [mpeg4 @ 0x7f39c58737c0] Error at MB: 0
> [mpeg4 @ 0x7f39c58737c0] illegal mb_num in video packet (1219 1170)
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] marker does not match f_code
> [mpeg4 @ 0x7f39c58737c0] illegal mb_num in video packet (1519 1170)

Can you upload the video? Do other players play it correctly?

Ronald


More information about the libav-api mailing list